The Emperor <the_emperor at m...> the_emperor at m...
Sat Dec 14 16:29:21 UTC 2002


> Looks a very good idea. A few quick comments:
> Sorry if you've discussed it before, but is there a good reason for 
> separate namespaces? I would have thought community & group (in the 
> context) could happily coexist.
You may be right - my thinking is that a community is a wrapper for 
FOAF files of people who visit and make up a specific entity like a 
website (or members of a village or something else like a pub?) while 
a group is a larger more conceptual/nebulous accumulation of 
individuals, sites, communities and other types of ways we define our 
interaction with each other.

It may be that the distinction is meaningless but I see the Community 
as being only one possible component of a group - it all depends on 
the approach to taxonomy that we take (splitting or lumping). 
Possibly an example might be a good idea.

> I'm still a little confused about the use of parent_group and 
sub_group, I
> suspect this could be simplified, though I like the general idea.
My thinking was that however, you try and define a group someone will 
always try and define a smaller or larger group to deal with more 
specific or broader interests and using parentGroup and subGroup (the 
point below being taken into account ;) ) would allow people to 
define their relationships to large or smaller groups. To avoid 
complication I'm tending to favour a bottom up approach so we would 
only have parentGroup (or superGroup possibly - making the 
subGroup/superGroup more meaningful) as high levels group documents 
like, e.g., Web designers would get very complicated quickly.

> Naming style - parentGroup, subGroup etc. would be more in keeping 
> current usage styles.

Good point - that is my PHP coding influence creeping in ;)
> sig:documentation - surely there's an existing term that could be 
used here?
> (offhand I can only think of seeAlso, which isn't quite enough)
Yes I suspect Dublin Core provides us with the tools to describe this.

> com:admintrator - typo.
Well spotted - thanks.


More information about the foaf-dev mailing list