[rdfweb-dev] Relationship property names

Ian Davis iand at internetalchemy.org
Fri Mar 19 12:21:59 UTC 2004


I've so far had three responses in favour of changing the property
names and three opposed. At the moment I'm inclined to make no changes
at all unless I hear a persuasive argument in favour of changing them.

Here's one aspect of the current naming convention which may influence
opinion. Most often the relationship being asserted is one that the
asserter is part of. When I use the current convention 'parentOf' I am
clearly making a statement about myself. If I use the alternative form
'child' I am making a statement about the person I'm asserting is my
child.

Is there actually a difference between these two forms, even a subtle
one? With inverse and symmetric properties this may be irrelevant, but
somehow it feels more natural the current way.

danbri suggested that properties should be named in a 'a P of
X is Y' style. This appears to work for properties that are context
free, e.g. name, depiction, pastProject. However
for properties describing requiring some context such as
based_near, holdsAccount, made, livesWith a different style is needed,
e.g. 'At some time X P Y"



Ian

-- 
http://internetalchemy.org | http://purl.org/NET/iand 




More information about the foaf-dev mailing list