[rdfweb-dev] Question about bio schema
AlexK at hcitraining.com
Fri Mar 19 17:11:00 UTC 2004
> There's bio:event the property and bio:Event the class.
> The bio:Event class is the base for other event classes.
Oh, ok. Like and abstract class.
> A person is linked to a bio:Event (or sub class) through a
> bio:event property,
OK, got it. I keep wanting to think in terms of regular object-oriented
design. I keep making this mistake, because I am not thinking in terms
of graphs. I think I am going to write a tutorial -- RDF for the
However, I think that the predicates could be named a little more
expressively. I always avoid having something that is the same name
except for the case of a letter. Instead of 'event', why not
'experienced' or 'experienceEvent' or 'hadEvent' or something like that?
More information about the foaf-dev