[rdfweb-dev] Relationship property names

Jeremy Gray jeremy at jeremygray.ca
Fri Mar 19 17:29:09 UTC 2004

The problem I see is that the general convention for properties reads like

X (has property) P (of value) Y


(the) P (of) X (is) Y

But your usage appears to be

X (is the) P (of value) Y

and is quite difficult to express in the second style from the convention.

Note the difference between the "X (has property)" and your "X (is the)".

Using the parent example, your is-based

X parentOf Y

Would, as far as I know, be more commonly expressed using a "has" style of

X child Y           (X (has) child Y)
Y parent X          (Y (has) parent X)

Or, to use the second style from the convention:

child X Y           ((the) child (of) X (is) Y)
parent Y X          ((the) parent (of) Y (is) X)

Jeremy Gray

-----Original Message-----
From: rdfweb-dev-bounces at vapours.rdfweb.org
[mailto:rdfweb-dev-bounces at vapours.rdfweb.org] On Behalf Of Ian Davis
Sent: Friday, March 19, 2004 4:22 AM
To: rdfweb-dev at vapours.rdfweb.org
Subject: Re: [rdfweb-dev] Relationship property names

I've so far had three responses in favour of changing the property names and
three opposed. At the moment I'm inclined to make no changes at all unless I
hear a persuasive argument in favour of changing them.

Here's one aspect of the current naming convention which may influence
opinion. Most often the relationship being asserted is one that the asserter
is part of. When I use the current convention 'parentOf' I am clearly making
a statement about myself. If I use the alternative form 'child' I am making
a statement about the person I'm asserting is my child.

Is there actually a difference between these two forms, even a subtle one?
With inverse and symmetric properties this may be irrelevant, but somehow it
feels more natural the current way.

danbri suggested that properties should be named in a 'a P of
X is Y' style. This appears to work for properties that are context free,
e.g. name, depiction, pastProject. However for properties describing
requiring some context such as based_near, holdsAccount, made, livesWith a
different style is needed, e.g. 'At some time X P Y"


http://internetalchemy.org | http://purl.org/NET/iand 

rdfweb-dev mailing list
rdfweb-dev at vapours.rdfweb.org
wiki: http://rdfweb.org/topic/FoafProject

More information about the foaf-dev mailing list